深入理解ospf

理解MPLS VPN 中对OSPF 层次化设计的补充 supper backbone area

2:理解MPLS VPN 中OSPF 的区域设计概念

3:理解MPLS VPN 中OSPF process id 和router-id 的重要性

4:理解MPLS VPN 中MP BGP 针对OSPF 的拓展团体属性,并且理解如何控制OSPF LSA 类型

domain-id

Extended Community: RT:1:1 OSPF
DOMAIN ID:0x0005:0x000000020200

OSPF RT:0.0.0.0:2:0 OSPF ROUTER
ID:11.1.1.1:0

mpls labels in/out
nolabel/23

5:理解MPLS VPN 中OSPF 利用down bit domain tag 防止环路

DownBit (vrf 相关)LSA 3

均在LSA中查阅

OSPF Tag
Fied

6:理解MPSL VPN 中back door route ,并且理解OSPF shame-link(伪链路)机制

Extended Community: RT:1:1 OSPF
DOMAIN ID:0x0005:0x000000020200
(由PE端的 ospf vrf相关联process计算得出)domain ID一致 此时看到的 都是3类(OIA)

OSPF RT:0.0.0.1(area
ID):

2(区域内或者区域间)

4(四类)

5(五类)外部

0 oe1

1 oe2

OSPF ROUTER
ID:11.1.1.1:0

mpls labels in/out
19/nolabel

OSPF 伪链路配置

1、在两端PE上
启用环回接口,(32位)lo1

(不能宣告进OSPF中)将接口lo1划入相关vrf中

interface Loopback1

ip vrf forwarding a(划入相对应的vrf中)

ip address 100.1.1.1
255.255.255.255(32位)

2、在BGP中起源(或者重分发)

network(redistribute)

router bgp 100

address-family ipv4 vrf
a

redistribute connected route-map A

route-map A permit 10

match interface
Loopback1

精确重分发lo1

在两端的vrf路由表中 学习到相对应的路由,并且互相能ping通

3、创建ospf sham-link

进入ospf 关联vrf a
的进程

router ospf 2 vrf a

area 0 sham-link 100.1.1.1
100.1.1.2

ce和PE之间的ospf区域(必须保证两端PE与CE之间区域一致)

当看到邻接关系是full状态
hello包被抑制 此时shamlink 建立成功,并且会形成新的邻居关系

此时查看CE端
ospf路由是否为O表项

如果为O表项
彻底建立成功

4、检查备份链路(备份cost值
比主链路(经过MPLSVPN) 大

interface Serial0/3

ip ospf cost 131

备份链路两端直连接口 都需要修改

静态

ip route 37.1.1.7 255.255.255.255
Serial0/0

ip route vrf a 0.0.0.0 0.0.0.0
11.1.1.2 global

router bgp 100

bgp router-id 2.2.2.2

address-family ipv4

redistribute static

ip route 37.1.1.7 255.255.255.255
Serial0/0

全局写静态路由(下一跳不可达)

ip route vrf a 0.0.0.0 0.0.0.0
11.1.1.2 global

VRF下写静态路由 下一跳为全局

Tunnel

R7与R3上同时启用tunnel接口

R7:interface Tunnel0

ip address 100.1.1.2
255.255.255.0

一定要在一个网段

tunnel source 37.1.1.7

tunnel destination
37.1.1.3

R3

interface Tunnel0

ip address 100.1.1.1
255.255.255.0

tunnel source 37.1.1.3

tunnel destination
37.1.1.7

tunnel vrf a(tunnel关联
vrf)

全场最佳!

R7与R3上同时启用tunnel接口

R7:interface Tunnel0

ip address 100.1.1.2
255.255.255.0

一定要在一个网段

tunnel source 37.1.1.7

tunnel destination
37.1.1.3

R3

interface Tunnel0

ip address 100.1.1.1
255.255.255.0

tunnel source 37.1.1.3

tunnel destination
37.1.1.7

tunnel vrf a(tunnel关联
vrf)

路由反射器

非客户的路由不会反射给非客户

其余均反射

MPLS VPN随堂笔记2的更多相关文章

  1. MPLS VPN随堂笔记2

    深入理解ospf 理解MPLS VPN 中对OSPF 层次化设计的补充 supper backbone area 2:理解MPLS VPN 中OSPF 的区域设计概念 3:理解MPLS VPN 中OS ...

  2. MPLS VPN随堂笔记1

    MPLS VPN 基础 1.MPLS vpn架构的特点 1.1.允许不同CE传递相同私网路由 1.2.SP内部(所有P路由器)不需要学习CE路由 1.3.无安全保障但有带宽保障(跟SP租用服务) 2. ...

  3. MPLS VPN随堂笔记1

    MPLS VPN 基础 1.MPLS vpn架构的特点 1.1.允许不同CE传递相同私网路由 1.2.SP内部(所有P路由器)不需要学习CE路由 1.3.无安全保障但有带宽保障(跟SP租用服务) 2. ...

  4. MPLS VPN随堂笔记3

    跨域 ASBR之间运行MPBGP 1.配置AS内部IGP保证环回口互相可达,同时建立LDP邻居 (优先启用 mpls label rang 16 100)方便查看实验现象 2.配置PE1-PE2 PE ...

  5. MPLS VPN随堂笔记3

    跨域 ASBR之间运行MPBGP 1.配置AS内部IGP保证环回口互相可达,同时建立LDP邻居 (优先启用 mpls label rang 16 100)方便查看实验现象 2.配置PE1-PE2 PE ...

  6. MPLS LDP随堂笔记2

    前一天排错 Acl 1 匹配所有ospf的数据包 (目的 ospf建立邻居关系 传递路由条目) 2 放行UDP报文 让LDP邻居能互相收发HELLO包 4 放行TCP报文 让LDP邻居能够建立TCP会 ...

  7. MPLS LDP随堂笔记1

    LDP 的使用原因(对于不同协议来说) LDP的四大功能 发现邻居 hello 5s 15s 224.0.0.2 发现邻居关系 R1 UDP 646端口 R2 UDP 646端口 此时形成邻居 建立邻 ...

  8. MPLS LDP随堂笔记2

    前一天排错 Acl 1 匹配所有ospf的数据包 (目的 ospf建立邻居关系 传递路由条目) 2 放行UDP报文 让LDP邻居能互相收发HELLO包 4 放行TCP报文 让LDP邻居能够建立TCP会 ...

  9. MPLS LDP随堂笔记1

    LDP 的使用原因(对于不同协议来说) LDP的四大功能 发现邻居 hello 5s 15s 224.0.0.2 发现邻居关系 R1 UDP 646端口 R2 UDP 646端口 此时形成邻居 建立邻 ...

随机推荐

  1. Loadrunner监控Linux系统资源

    一.安装rsh和rpcbind 1.查看是否安装:rpm -qa |grep rsh 2.安装rsh:yum -y install rsh* 3.yum  -y install nfs-utils r ...

  2. JENKINS基础使用

    JENKINS总结 修改时间 修改内容 修改人 2016.3.12 创建 刘永志 2016.5.22 添加tomcat+jenkins 刘永志 2016.6.14 添加tomcat找不到ant解决方案 ...

  3. Linux:永久修改网卡的MAC地址

    比如:搭建一个虚拟机环境之后,需要N个一样的系统,可以本地复制虚拟机来实现.但是复制之后,网卡的MAC地址一样,无法使用,这时候需要修改网卡的MAC地址,且希望重启系统之后,仍生效的,步骤如下: 1. ...

  4. SQL Server数据库学习总结

    经过一段时间的学习,也对数据库有了一些认识,数据库基本是由表,关系,操作组成:对于初学者首先要学的     一图胜“十”言:SQL Server 数据库总结 一个大概的总结 经过一段时间的学习,也对数 ...

  5. Teamcity+SVN+VisualStudio在持续集成简明教程

    Teamcity+SVN+VisualStudio持续集成 简明教程 一.写在最前: 1.      各组件版本号例如以下: Teamcity(简称tc)版本号:8.1.4 SVN版本号:Tortoi ...

  6. HDU 5185 Equation (DP)

    题目:LINK 题意:求满足题目要求的x序列的种类数. 能够发现符合条件的序列去重后是一个0, 1, ..., k的连续序列(k满足k*(k+1)/2 <= n) ,则这个去重后的序列长度最长为 ...

  7. 调试设置移动端Web开发环境搭建实践

    新手发帖,很多方面都是刚入门,有错误的地方请大家见谅,欢迎批评指正 本文重要总结一下挪动端进行前端开发时需要用到的一些工具,以及他们之间互相的组合,同时也包含本人应用的组合. 1. Chrome To ...

  8. windows和linux下关闭Tomcat进程

    windows和linux下解决Tomcat进程 windows下启动Tomcat报错,8080端口号被占用,报错信息如下 两种解决方法,一种是关闭了这个端口号,另外一种是修改Tomcat下的serv ...

  9. 验证代理IP

    ##author:wuhao#import urllib.requestfrom http import cookiejar import xlrd import threading #有效的代理,可 ...

  10. 【iOS】Swift if let 和 if var

    if let unwrappedOptional = postDict { print("The optional has a value! It's \(unwrappedOptional ...