我使用的Eclipse版本是3.7(Indigo)

通过Eclipse的help选项,点击“Install New Software...”弹出安装对话框,

点击add按钮,在Location里输入http://download.eclipse.org/technology/m2e/releases/1.3然后就可以选择安装。

如下图所示:

这里如果m2e的版本选择是的1.4,则会报错:

Cannot complete the install because one or more required items could not be found.
Software being installed: m2e - Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.feature.feature.group 1.4.0.20130601-0317)
Missing requirement: Embedded Maven Runtime Bundle 1.4.0.20130531-2315 (org.eclipse.m2e.maven.runtime 1.4.0.20130531-2315) requires 'bundle org.slf4j.api 1.6.2' but it could not be found
Cannot satisfy dependency:
From: Maven Archetype Common Bundle 1.4.0.20130531-2315 (org.eclipse.m2e.archetype.common 1.4.0.20130531-2315)
To: bundle org.eclipse.m2e.maven.runtime [1.4.0,1.5.0)
Cannot satisfy dependency:
From: m2e - Maven Integration for Eclipse 1.4.0.20130601-0317 (org.eclipse.m2e.feature.feature.group 1.4.0.20130601-0317)
To: org.eclipse.m2e.maven.indexer [1.4.0.20130531-2315]
Cannot satisfy dependency:
From: Maven / Nexus Indexer Bundle 1.4.0.20130531-2315 (org.eclipse.m2e.maven.indexer 1.4.0.20130531-2315)
To: bundle org.eclipse.m2e.archetype.common [1.4.0,1.5.0)

解决方法就是:m2e的版本选择1.3/1.2或者升级eclipse版本。