1.打开终端

2.移除现有 Ruby 默认源 输入以下指令

$gem sources --remove https://rubygems.org/

3.使用新的源 输入以下指令

$gem sources -a https://ruby.taobao.org/

4.验证新源是否替换成功 输入以下指令

$gem sources -l

5.安装 CocoaPods

$sudo gem install cocoa pods

//–––––––––––那么问题来了——没遇到的自动跳过————————————

错误提示1

Error installing cocoapods:  activesupport requires Ruby version >= 2.2..

解决方案 :

1、安装 RVM baby 版本管理器

$curl -L get.rvm.io | bash -s stable

//________等安装完成 出现下面这行提示以下___________

In case of problems: https://rvm.io/helpandhttps://twitter.com/rvm_io

执行

$source ~/.bashrc  
$source ~/.bash_profile

测试是否安装正常

$rvm -v 

//________提示以下___________

rvm 1.27.0 (latest) by Wayne E. Seguin, Michal Papis[https://rvm.io/]

2、用RVM升级Ruby查看当前ruby版本

 $ruby -v 
$rvm list known
//________提示以下___________

# MRI Rubies

[ruby-]1.8.[-p420]

[ruby-]1.8.[-head] # security released on head

[ruby-]1.9.[-p431]

[ruby-]1.9.[-p330]

[ruby-]1.9.[-p551]

[ruby-]2.0.[-p648]

[ruby-]2.1[.]

[ruby-]2.2[.]

[ruby-]2.3[.]

[ruby-]2.2-headruby-head

# for forks use: rvm install ruby-head---url https://github.com/github/ruby.git --branch 2.2

# JRuby

安装ruby 2.2.2 执行

$rvm install 2.2.

如果打印:

……  ruby-2.2. - #validate archive
ruby-2.2. - #extract
ruby-2.2. - #validate binary
ruby-2.2. - #setup
ruby-2.2. - #gemset created /Users/abc/.rvm/gems/ruby-2.2.@global
ruby-2.2. - #importing gemset
/Users/abc/.rvm/gemsets/global.gems..............................
ruby-2.2. - #generating global wrappers........
ruby-2.2. - #gemset created /Users/abc/.rvm/gems/ruby-2.2.
ruby-2.2. - #importing gemsetfile /Users/abc/.rvm/gemsets/default.gems
  evaluated to empty gem list
ruby-2.2. - #generating default wrappers........
Updating certificates in '/etc/openssl/cert.pem'.
mkdir: /etc/openssl: Permission denied
mkdir -p "/etc/openssl" failed, retrying with sudo
LiuWenqiang password required for 'mkdir -p /etc/openssl':
and sudo mkdir worked

则说明安装成功了

打印代码:

Done with Command Line Tools (OS X 10.11) for Xcode
Done.
==> /usr/bin/sudo /bin/rm -f /tmp/.com.apple.dt.CommandLineTools.installondemand.in-progress
==> Installing the Command Line Tools (expect a GUI popup):
==> /usr/bin/sudo /usr/bin/xcode-select --install
xcode-select: error: command line tools are already installed, use "Software Update" to install updates
Failed during: /usr/bin/sudo /usr/bin/xcode-select --install
Requirements installation failed with status: .

4.  继续安装 CocoaPods

$sudo gem install cocoa pods

$sudo gem install -n /usr/local/bin cocoapods

$pod setup

5.  更新 gem

$sudo gem update --system

6.  新建一个项目,名字PodTest

7.    $ cd  项目路径 (中间有空格,)

    cd /Users/lucky/Desktop/PodTest   

8.   建立Podfile(配置文件)

 $vim Podfile

键盘输入" i "进入编辑模式,输入

platform :ios, '7.0' 

pod 'MBProgressHUD', '~> 0.8’ (之前的,我的电脑上已经无效了,报错: [!] The dependency `MBProgressHUD (~> 0.8)` is not used in any concrete target.)

(现在使用:MyApp 替换成自己的项目名)

target 'MyApp' do

pod 'AFNetworking', '2.6'

pod 'ORStackView', '3.0'

end

然后

按Esc,并且输入“ :”号进入vim命令模式,然后在冒号后边输入wq

再输入

 $pod install

注意:现在打开项目不是点击 PodTest.xodeproj了,而是点击 PodTest.xcworkspace

为了确定AFNetworking是否支持CocoaPods,可以用CocoaPods的搜索功能验证一下。在终端中输入:

$ pod search AFNetworking

###如果安装失败

干货1:

安装ruby遇到" Installing Homebrew - Brew Command Not Found"命令找不到解决方案:

Check XCode is installed or not.

$gcc --version

$ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

$brew doctor

$brew update.

完成后 执行

$ruby -v
//–––––打印输出–––––––

ruby 2.2.2p95 (-- revision ) [x86_64-darwin14]

6 继续安装 CocoaPods

$sudo gem install cocoa pods
//______安装成功提示如下______

Done installing documentation for nap, fourflusher, escape, colored, concurrent-ruby, thread_safe, tzinfo, i18n, activesupport, claide, xcodeproj, molinillo, cocoapods-try, netrc, cocoapods-trunk, cocoapods-stats, cocoapods-search, cocoapods-plugins, cocoapods-downloader, cocoapods-deintegrate, fuzzy_match, cocoapods-core, cocoapods after  seconds, gems installed
$pod setup

备注:苹果系统升级 OS X EL Capitan 后安装改为:

$sudo gem install -n /usr/local/bin cocoapods
$pod setup

干货2:

CocoaPods无限卡在Setting up CocoaPods master repo解决方案:

对于初次使用CocoaPods的同学,即使你不使用pod setup命令,在你初次执行pod install命令时,系统也会自动执行pod setup。而由于网络不稳定的原因,不挂VPN是不可能成功执行pod setup的。(我大天朝的墙啊~~~~)

$ pod repo remove master

$ git clone https://github.com/CocoaPods/Specs.git ~/.cocoapods/repos/master

$ pod repo update

7 更新 gem

$sudo gem update --system

8 新建工程,并在终端用 cd 指令到文件夹内

$pod search 第三方库

9 新建 Podfile 文件

$ touch Podfile

10 编辑 Podfile 文件,并写入要添加的第三方库(cocoapod1.0.1版本Podfile文件的内容格式要求发生了变化,必须指出指出所用第三方库的target)

platform:ios, '8.0'

#use_frameworks!个别需要用到它,比如reactiveCocoa

target 'XXXApp' do

pod 'AFNetworking', '2.3.1'<-------第三方

end

11 导入第三方库

$pod install --no-repo-update
xcode-select: error: command line tools are already installed, use "Software Update" to install updates
Failed during: /usr/bin/sudo /usr/bin/xcode-select --install
Requirements installation failed with status: . 此时查询Xcode,切换到另一个环境: $ sudo xcode-select --switch /Library/Developer/CommandLineTools/
Password:
$ git
usage: git [--version] [--help] [-C <path>] [-c name=value]
[--exec-path[=<path>]] [--html-path] [--man-path] [--info-path]
[-p | --paginate | --no-pager] [--no-replace-objects] [--bare]
[--git-dir=<path>] [--work-tree=<path>] [--namespace=<name>]
<command> [<args>]
ERROR: Error installing cocoapods:
activesupport requires Ruby version >= 2.2..
localhost:~ zzz$ $curl -L get.rvm.io | bash -s stable
-bash: -L: command not found
localhost:~ zzz$

解决方法:

ruby -e "$(wget -qO - 'https://raw.github.com/mxcl/homebrew/go')" 

$ sudo xcode-select --switch /Library/Developer/CommandLineTools/

Password: (输入电脑权限密码)

$ git
usage: git [--version] [--help] [-C <path>] [-c name=value]

[--exec-path[=<path>]] [--html-path] [--man-path] [--info-path]

[-p | --paginate | --no-pager] [--no-replace-objects] [--bare]

[--git-dir=<path>] [--work-tree=<path>] [--namespace=<name>]

<command> [<args>]
 

Cocoapods的安装报错 - Error installing pods:activesupport requires Ruby version >=2.2.2的更多相关文章

  1. iOS的CocoaPods(activesupport requires Ruby version &gt;= 2.2.2)

    如果你在安装遇到这个问题 activesupport requires Ruby version >= 2.2.2,那么这里可以帮助你(lasted version) 如果你是通过 http:/ ...

  2. go报错unimplemented: 64-bit mode not compiled in与mingw 64位安装报错ERROR res已解决

    问题一:cc1.exe: sorry, unimplemented: 64-bit mode not compiled in 参考:https://www.cnblogs.com/lesroad/p/ ...

  3. CocoaPods 报错 [!] Error installing JSONModel

    pod install p.p1 { margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #34bd26 } span.s1 { } ...

  4. python3 pip 安装Scrapy在win10 安装报错error: Microsoft Visual C++ 14.0 is required. Get it with &quot;Microsoft Visual C++ Build Tools&quot;: http://landinghub.visualstudio.com/visual-cpp-build-tools

    问题描述 当前环境win10,python_3.6.1,64位. 在windows下,在dos中运行pip install Scrapy报错: building 'twisted.test.raise ...

  5. python安装报错error writing to file:......

    今天换了win10 64电脑,安装python3.6.8时,报错:error writing to file:...... 安装时,右键--以管理员身份运行,安装成功.

  6. wordcloud的安装报错 error: Microsoft Visual C++ 10.0 is required. Get it with &quot;Microsoft Windows SDK 7.1&quot;解决办法

    cmd中使用pip install wordcloud失败,没看懂报错的原因…… 而在pycharm中添加也报错 解决方法: 1. 下载wordcloud-1.4.1.tar.gz,解压缩 cmd c ...

  7. mha安装报错 [error][/usr/share/perl5/vendor_perl/MHA/MasterMonitor.pm, ln361] None of slaves can be master. Check failover configuration file or log-bin settings in my.cnf

    查找资料 参考 http://blog.51cto.com/16769017/1878451 解决方法: 在两个从库上开启二进制日志即可(花了 一天时间,找不到解决方法,最后还是靠自己的理解及测试解决 ...

  8. memcached安装报错 error while loading shared libraries: libevent-2.0.so.5: cannot open shared object file: No such file or directory解决

    我是从其他服务器scp来的memcached(~~~整个文件夹的那种,windows用多了的后遗症) 在准备运行 ./memcached -d -u root -l localhost -m 800 ...

  9. Windows10反安装报错error code 2502 2503

    先找系统TEMP目录,一般为C:\windows\temp,打开这个目录的权限,为这个目录中的User用户添加权限为完全控制,现在再反安装就不会报错了. 注:原因就是因为系统运行时需要用到临时文件的目 ...

随机推荐

  1. CentOS光盘挂载命令以及安装软件

    最近又学习了一个命令:mount 挂载命令,我们在安装软件的时候,直接敲命令install 包名,但是这里其实是联网安装的, 如果使用光盘,从本地安装就要使用mount命令. 1.我的linux系统是 ...

  2. 关于git,你需要知道一点命令

    最近有朋友经常问git的一些操作,写在这里与大家分享,以后也不用一一解释了.惯例,这是基础分享,从安装开始说起: 安装: 去这里 https://git-scm.com/ 找到你所需要的版本,下载并安 ...

  3. Javascript函数重载,存在呢—还是存在呢?

    1.What's is 函数重载? );//Here is int 10 print("ten");//Here is string ten } 可以发现在C++中会根据参数的类型 ...

  4. C# Reflection BindingFlags

    定义包含在搜索中的成员 下列 BindingFlags 筛选标志可用于定义包含在搜索中的成员: 为了获取返回值,必须指定 BindingFlags.Instance 或 BindingFlags.St ...

  5. jQuery的无new实例化

    我只能说想法很好,设计的巧妙.看代码: var jQuery = function( selector, context ) { //执行了init函数并返回jQuery实例 return new j ...

  6. ecshop 在php5.5上安装错误解决

    1.找到ecshop\includes\cls_image.php文件 搜索 function gd_version 改成 static function gd_version 2.Strict St ...

  7. HDOJ-三部曲一(搜索、数学)-1008-Prime Path

    Prime Path Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other) Total S ...

  8. DAX/PowerBI系列 - 父子层级(Parent-Child Hierarchy)

    DAX/PowerBI系列 - 父子层级(Parent-Child Hierarchy)参考文章见最后 难度: ◆◆◇◇◇(2星) 应用场景: 其实很多时候对数据汇总都会有层级关系的问题,不过说的不是 ...

  9. tensorflow estimator API小栗子

    TensorFlow的高级机器学习API(tf.estimator)可以轻松配置,训练和评估各种机器学习模型. 在本教程中,您将使用tf.estimator构建一个神经网络分类器,并在Iris数据集上 ...

  10. jvm系列(1):JVM问答

    一:JVM基础知识 1)Java 是如何实现跨平台的? 注意:跨平台的是 Java 程序,而不是 JVM.JVM 是用 C/C++ 开发的,是编译后的机器码,不能跨平台,不同平台下需要安装不同版本的 ...